Doel:€250.00
Donaties:€172.50

Per saldo:€-77.50

Steun ons nu!

Laatst bijgewerkt
op 12-01-2021
Algemeen

De stichting

Recente berichten

Artitec Hondekop IC-uitvoering, model 2020, materieelbespreking. door Spoor010
Vandaag om 23:11:50
Gezocht: Roco motor 85113, of soortgelijk door meino
Vandaag om 23:06:03
Klein Hertogdom Moresnet in H0 door Wim Vink
Vandaag om 22:59:14
Projekt 083-338 door 44
Vandaag om 22:49:44
Roco NS 200/300 Sik, model 2019 door Huup
Vandaag om 22:41:33
Uit en Thuis, de bouw door Klaas Zondervan
Vandaag om 22:25:49
Vragen over keerlus, en benodigde digitale onderdelen. door Juroen
Vandaag om 22:19:40
Pimp my Fleischmann BR01 164 ==> Lofzang op een Fleischmann BR 01 door Karst Drenth
Vandaag om 22:08:21
Ontstaan van module/ diorama baan De Lagerweij door jaco1988
Vandaag om 21:57:44
Toon hier je nieuwe (model-) spooraanwinst(en)... door barry1972
Vandaag om 21:56:26
Digikeijs DR5000 Centrale, productbeschrijving door Karst Drenth
Vandaag om 21:47:26
Electrotren 1300, probleem bij Marklin M-rails wissel. door NL-modelspoor
Vandaag om 21:45:43
Stoomtrein Goes Borsele: Wat zijn we aan het bouwen door barry1972
Vandaag om 21:44:52
Philotrain 3759 door roadster36
Vandaag om 21:36:11
Mijn eerste H0-modeltreinbaan in aanbouw door Frycio82
Vandaag om 21:22:17
3D/RM: Stadler Flirt 3 in 1:160 door Stick
Vandaag om 21:13:22
"Litter Bin" voor Brits spoor en Britse modelspoorprojecten door St00mboy
Vandaag om 21:09:12
NL baan: Frotterdam in h0 door SvenW
Vandaag om 21:01:51
LTM-51 Garratt in messing, Spoor-0 door FritsT
Vandaag om 20:50:33
Hoe Nederlandse wisselsteller plaatsen? door Mitchell
Vandaag om 20:37:44
Gezocht: Lima H0 motors door Biesje@work
Vandaag om 20:36:46
Mehano Blue Tiger DCC, loopt slecht. Decoder defect? door hein frunt
Vandaag om 20:34:40
Haven/industrie rangeerbaantje in spoor 0 door Hans_omBC
Vandaag om 20:33:42
Deining in Dönsdorf door Basilicum
Vandaag om 20:33:42
Onlangs gespot - gefotografeerd, de foto's door dh3201
Vandaag om 20:22:48
Loof en bladeren, welke leveranciers zijn er? door Wim Janse
Vandaag om 19:37:25
3-weg wissel aansluiten, en terugmelding d.m.v. leds? door Pascal77
Vandaag om 19:13:38
Bad Burgstein door ruben derks
Vandaag om 19:13:19
Falkenheim door Falcon10
Vandaag om 19:08:53
Depot + vervolg Vlieringen-2 door Hans Reints
Vandaag om 19:03:50
  

Auteur Topic: Rocrail gebruikersgroep  (gelezen 14046 keer)

AlbertG

  • Offline Offline
  • Berichten: 436
    • Modelbaan Den Akker
Re: Rocrail gebruikersgroep
« Reactie #135 Gepost op: 01 november 2020, 19:35:16 »
@Allen
Je kunt op dit moment niet bestellen bij Peter Giling omdat hij brand heeft gehad in zijn werkplaats. Medio november gaat hij weer leveren.

@Ron,
Als je automatisch opslaan aanzet zoals ik hierboven beschreven heb worden alle wijzigingen bewaard.
Hartelijke groeten,
Albert

ron.kraaijkamp

  • Offline Offline
  • Berichten: 164
    • Mijn baan in opbouw op 2RSweb
Re: Rocrail gebruikersgroep
« Reactie #136 Gepost op: 02 november 2020, 07:35:15 »
@Allen
Je kunt op dit moment niet bestellen bij Peter Giling omdat hij brand heeft gehad in zijn werkplaats. Medio november gaat hij weer leveren.

@Ron,
Als je automatisch opslaan aanzet zoals ik hierboven beschreven heb worden alle wijzigingen bewaard.

Ik heb het automatisch opslaan inmiddels aangezet. De vragen en antwoorden halen elkaar zo af en toe in.
Van het weekend niet zo veel tijd gehad. Gisterenavond wel resultaat op de baan.

De loc rijdt nu automatisch zijn rondjes, wissels gaan om waar nodig, enz. Ik bedien de enter en in sensors nog met de hand, afhankelijk waar de loc dan op de baan is.
Nu moet ik mijn Okkies en Loconet shiled gaan solderen. Dinsdag komt de converter binnen om e.e.a. aan de PC te koppelen.

Als dat klaar is (schaduw station), kan ik beginnen aan de hoofdbaan.

Mvg, Ron

AlbertG

  • Offline Offline
  • Berichten: 436
    • Modelbaan Den Akker
Re: Rocrail gebruikersgroep
« Reactie #137 Gepost op: 02 november 2020, 12:35:05 »
Hi Ron,
Mooi dat het nu werkt. Fijn dat je het even laat weten.
Heb je de Loconet-USB converter van Rosoft gekocht?
Succes met uitbouwen van je baan.
Hartelijke groeten,
Albert

ron.kraaijkamp

  • Offline Offline
  • Berichten: 164
    • Mijn baan in opbouw op 2RSweb
Re: Rocrail gebruikersgroep
« Reactie #138 Gepost op: 03 november 2020, 07:11:34 »
Hi Ron,
Heb je de Loconet-USB converter van Rosoft gekocht?

Hi Albert,

Ja, die heb ik besteld. Als het goed is komt die vanmiddag binnen.
Ik moet nog wel eerste de printjes voor de terug melders solderen (Okkies en Loconetshield). Dat gaat van het weekend denk ik gebeuren.
En even kabels organiseren.

ron.kraaijkamp

  • Offline Offline
  • Berichten: 164
    • Mijn baan in opbouw op 2RSweb
Re: Rocrail gebruikersgroep
« Reactie #139 Gepost op: 11 november 2020, 15:00:12 »
Hi Allemaal,

Inmiddels de Loconet naar USB adapter van Rosoft binnen.
Ik kreeg het niet aan de gang. En dat lag natuurlijk aan mij.

Door me niet voldoende te verdiepen in het hele Loconet verhaal, ging ik er van uit dat het simple koppelen van de adapter en de Arloco shield voldoende zou zijn.
Wim Ros heeft me op de goede weg geholpen en aangegeven dat Loconet een stroombron nodig heeft en spanning op de twee buitenste aders.
Rosoft heeft daar een oplossing voor.

Nu ik me wel had ingelezen ben ik aan het experimenteren geslagen. Ik heb een schema op internet gevonden en dat gebouwd.
En ja hoor, nu werkt het. Wanneer ik op het Loconet Shield een ingang naar nul breng zie ik netjes de sensor in Rocrail veranderen van status.

Nu is de vraag of de adapter, en met name de baudrate (19200), toereikend is om mijn 33 blokken en dus 66 sensors af te handelen.
De toekomst zal het lezen.

Allen bedankt voor de input.

Mvg, RonK

Karst Drenth

  • Offline Offline
  • Berichten: 9550
  • NS blauw, groen, rood, bruin, grijs en standgroen
    • Plan U op Sleutelspoor
Re: Rocrail gebruikersgroep
« Reactie #140 Gepost op: 11 november 2020, 15:09:24 »
Citaat van: ron.kraaijkamp
Nu is de vraag of de adapter, en met name de baudrate (19200), toereikend is om mijn 33 blokken en dus 66 sensors af te handelen.

Geen beren zien waar ze niet kunnen zijn.... ;)

Citaat van: ron.kraaijkamp
Nu ik me wel had ingelezen ben ik aan het experimenteren geslagen.

Iets verder lezend had je namelijk gezien ( ;) ) , dat de baudrate van LocoNet zelf 16666 baud is... 19200 is dus RUIIIIIMMMMM voldoende voor jouw 66 melderingangen ;) Ik ken mensen met banen met meer dan 10x zoveel :o

Grtzz & suc6,
Karst

ron.kraaijkamp

  • Offline Offline
  • Berichten: 164
    • Mijn baan in opbouw op 2RSweb
Re: Rocrail gebruikersgroep
« Reactie #141 Gepost op: 11 november 2020, 15:31:25 »
Iets verder lezend had je namelijk gezien ( ;) ) , dat de baudrate van LocoNet zelf 16666 baud is... 19200 is dus RUIIIIIMMMMM voldoende voor jouw 66 melderingangen ;) Ik ken mensen met banen met meer dan 10x zoveel :o

Dat is geruststellend. Gaat het vast en zeker goed komen.

Ik ben een elctronicus en IT-er. Dus lees zo min mogelijk handleidingen  ;D.
Ooit eens een heel uitgebreid systeem bij een klant moeten afleveren. Dan heb je het over kabinetten vol apparatuur. En dan het configureren ervan. Er stond achterin de handleiding bij de index, vet gedrukt, "Engineers, start reading from the first page!". Niets bijgeleerd, zal ik zelf maar zeggen.

MvG, Ron

ron.kraaijkamp

  • Offline Offline
  • Berichten: 164
    • Mijn baan in opbouw op 2RSweb
Re: Rocrail gebruikersgroep
« Reactie #142 Gepost op: 05 januari 2021, 20:27:28 »
Nieuwe uitdaging.

Arloco en Okkies zijn in elkaar gesoldeerd en werken goed. De "Enter" en "In" melders komen goed binnen bij Rocrail.



Melders S0-bkl01 t/m S0-bkl07 zijn aangesloten (de gele blokken) op de Arloco en Okkies. Wanneer de loc daar rijdt, wordt dat netjes terug gemeld in Rocrail.

Nu wil ik de loc van blok S0-blk10 naar S0-bkl12 rijden. In de aangegeven rijrichting.
Ik sleep de loc in S0-blk10. Pas de verwissel de "blok logisch kant/swap logical direction" zodat die in de richting van de rijrichting wijst.
Dan sleep ik de loc van blok S0-blk10 naar S0-blk12. De wissels worden omgezet zodat de loc via blok S0-blk07 rijdt. En de loc begint te rijden in de richting van de rijrichting.
In blok S0-blk07 wordt een willekeurige tijd gewacht, zoals de bedoeling is. Wanneer de loc in blok S0-blk12 is stop ik 'm. Anders heb ik straks een gevalletje Spijkenisse.
Ik doe een "Reset All" en de blokken worden vrijgegeven. Dan de rijspanning er weer op. En laat ik de loc handmatig terug rijden naar blok S0-blk10.

Dan staat de loc met de frontlichten richting het "zuiden" te wijzen.
Dan sleep ik de loc weer in blok S0-blk12, zet de automatische mode aan en sleep de loc van S0-blk12 naar S0-blk12. De loc begint te rijden. Alleen in zuidelijke richting. Terwijl in Rocrail de rijrichting in noordelijke richting staat aangegeven. Wanneer je de loc via de throttle de andere kant op laat rijden, komt deze in S0-blk07, stop daar even en rijdt.... terug naar S0-blk12.
Ook de rijrichting pijl in de snelheids regelaar is dan omgedraaid t.o.v. de echte rijrichting.

En een volgende keer is het weer correct.
Je zou verwachten dat Rocrail de loc in de juiste richting zal laten rijden.
Het lijkt erop dat de loc na elke keer terug rijden, de standaard rijrichting van de loc heeft omgegooid.

Een goede vriend van me, en ik vermoed het ook, denkt dat het te maken heeft met het feit dat de andere blokken nog niet gedetecteerd worden. En Rocrail dus niet meer weet waar de loc uithangt. Ook al zet ik 'm weer terug in een blok.

Er zal wel een verklaring voor zijn, ik zien 'm nog niet.

Als de loc eerst helemaal door moet kunnen rijden en alle blokken gedefinieerd moeten zijn, dan kan ik beter verder gaan met het bouwen van mijn hoofdbaan. Alles aansluiten en testrijden.
Virtueel kan ik wel gewoon rijden. In de juiste richting. Dan heb je natuurlijk niets met echte detectie te maken.

ron.kraaijkamp

  • Offline Offline
  • Berichten: 164
    • Mijn baan in opbouw op 2RSweb
Re: Rocrail gebruikersgroep
« Reactie #143 Gepost op: 05 januari 2021, 20:56:47 »
Nog een andere vraag.

Bij een van mijn Lima loc (BR184), zie ik het volgende in het server venster:
20210105.203916.879 r9999I 000020CC OLoc     1019 lc=BR184 dir=0 fn=1
20210105.203916.879 r9999I 000020CC OLoc     1034 set loco BR184 field direction to fwd
20210105.203916.879 r9999I 000020CC OLoc     1075 lc=BR184 V=0(0)
20210105.203916.879 r9999I 000020CC OLoc     1105 loco BR184 check consist members for command lc:dirfun
20210105.203916.879 r9999I 000020CC OLoc     1116 lc=BR184 V_raw=0 V=0 fn=1 dir=Forwards throttleID=virtual
20210105.203917.852 r9999I 00000238 OLocoNet 1885 Trying to get slot for loco addr=3.
20210105.203918.843 r9999E 00000238 OLocoNet 1952 Could not get slot for loco addr=3. (no response...)
20210105.203918.843 r9999c 00000238 ODCCPP   0585 loco BR184 addr=3 V=0 dir=1 slot=1
20210105.203918.859 r9999c tid0x04E OVirtual 0523 id=BR184: addr=3, protocol=default, calculated speed=0, command=- V=0, dir=fwd, lights=on, throttleid=rv2788

Dat zie ik bijvoorbeeld wanneer ik de rijrichting verander. Dat werkt ook vertraagd. Net de decoder naar defaults terug gezet. Dat maakte niets uit.
Een andere Lima loc met hetzelfde type decoder, heeft hier geen last van.
Het lijkt iets met Loconet te maken. Ik kan alleen niet snappen hoe dan. Ik stuur de loc(s) aan via een Arduino met een motorshield. De Loconet interface gaat via een andere USB poort.
Ik verwacht eigenlijk dat het te maken heeft met een instelling voor de loc in Rocrail. Kan het alleen niet vinden.
Of de decoder is niet lekker (meer, want het heeft wel goed gewerkt).

Toch denk ik dat het in de instellingen van Rocrail zit. Met name voor deze loc. In JMRI rijdt de loc de juiste kant op en zit er geen seconde vertraging in het wisselen van de verlichting, wanneer deze stil staat.
« Laatst bewerkt op: 05 januari 2021, 21:07:27 door ron.kraaijkamp »

Hans1963

  • Offline Offline
  • Berichten: 111
  • Spoor 0, dat wordt wel wat!
Re: Rocrail gebruikersgroep
« Reactie #144 Gepost op: 06 januari 2021, 00:16:06 »
Je werkt zo te zien met 2 centrales in Rocrail.
een DCC++ centrale voor de locs en een Loconet centrale voor de accessoires.

dat betekent ook 2 interface ID's
heb je bij de LIMA loc de juiste ID gekozen?
vr. groet,  Hans

ron.kraaijkamp

  • Offline Offline
  • Berichten: 164
    • Mijn baan in opbouw op 2RSweb
Re: Rocrail gebruikersgroep
« Reactie #145 Gepost op: 06 januari 2021, 09:10:23 »
Je werkt zo te zien met 2 centrales in Rocrail.
een DCC++ centrale voor de locs en een Loconet centrale voor de accessoires.

dat betekent ook 2 interface ID's
heb je bij de LIMA loc de juiste ID gekozen?

Hallo Hans,

Ja, dat klopt. Een DCC++ centrale om de loc aan te sturen en een Loconet "centrale" voor de terugmeldingen.
Ik kan wel met de locrijden.

Je hebt me wel op het goede been gezet. Bij Interface staat "all" aangevinkt. Dus ik denk dat Rocrail dan eerst met de Loconet interface de loc probeert aan te sturen.
Nu vinkje weggehaald (werk op afstand) en dan vanavond maar even testen met de loc. Al mijn andere locs hadden dit vinkje niet. Dus het is erg aannemelijk dat dit de oplossing is.

Bedankt, ik laat het resultaat weten.

Mvg, Ron

ron.kraaijkamp

  • Offline Offline
  • Berichten: 164
    • Mijn baan in opbouw op 2RSweb
Re: Rocrail gebruikersgroep
« Reactie #146 Gepost op: 06 januari 2021, 19:49:26 »
Hans, all,

Het probleem met de Lima Br184 is opgelost. Reageert meteen en geen fout melding meer in het server window.

Bedankt.

Iemand een idee over mijn andere vraag? Waarom een loc een willekeurige richting schijnt te nemen?

Mvg, Ron

Hans1963

  • Offline Offline
  • Berichten: 111
  • Spoor 0, dat wordt wel wat!
Re: Rocrail gebruikersgroep
« Reactie #147 Gepost op: 06 januari 2021, 21:22:03 »
Mooi dat het nu werkt Ron.

en wat betreft de andere vraag:
je rijdt de loc handmatig terug naar blok 10 (dus achteruit)
heb je de rijrichting daar aangekomen weer goed gezet?

de richtingspijlen >> in de throttle moeten altijd vooruit wijzen in de automode.
bekijk het filmpje van Albert maar eens.


https://youtu.be/fxUkJszTDqo

vr. groet,  Hans

ron.kraaijkamp

  • Offline Offline
  • Berichten: 164
    • Mijn baan in opbouw op 2RSweb
Re: Rocrail gebruikersgroep
« Reactie #148 Gepost op: 07 januari 2021, 13:27:06 »
Hans,

Bedankt voor de tip.

Ik realiseerde me deze al bekeken te hebben en zelfs de laatste "dia" te hebben uitgeprint.
Ik ga vanavond of van het weekend nog eens kijken wat ik fout heb gedaan.

Ik heb al veel gehad aan de video's van Albert. Ik heb ze dus niet allemaal onthouden  ;).

Mvg, Ron

AlbertG

  • Offline Offline
  • Berichten: 436
    • Modelbaan Den Akker
Re: Rocrail gebruikersgroep
« Reactie #149 Gepost op: 07 januari 2021, 18:32:39 »
en een Loconet "centrale" voor de terugmeldingen.

Hoi Ron,
Kun je me vertellen wat voor "centrale" dit is?
Hartelijke groeten,
Albert