Doel:€250.00
Donaties:€65.00

Per saldo:€-185.00

Steun ons nu!

Laatst bijgewerkt
op 17-03-2020
Algemeen

De stichting

Recente berichten

Koppeling weg. Oplossingen? door Dick55
Vandaag om 20:24:16
Baanbouw Bosje77 door Wim Vink
Vandaag om 20:23:05
Kleine boutjes vastzetten? door ruudns
Vandaag om 20:18:23
Vieze treinen, gebouwen, wegen etc. (tips en plaatjes) door nkob
Vandaag om 20:16:02
63410 via i train z21 licht laten schakelen door Harry de kaste
Vandaag om 20:12:27
Probleem met ingebouwde decoder. door jerrytrein
Vandaag om 20:11:53
Oeps door Eric B
Vandaag om 19:47:57
Old England door St00mboy
Vandaag om 19:42:12
Haven/industrie rangeerbaantje in spoor 0 door Noordernet
Vandaag om 19:38:29
De fabriek - Spoor 0 door sdz1976
Vandaag om 19:33:34
Mijn eerste H0-modeltreinbaan in aanbouw door tuurtje
Vandaag om 19:24:50
Länderbahn en Reichsbahn locomotieven. door puntenglijder
Vandaag om 19:14:35
wisseladres invoeren LDT decoder in Intellibox II?? door Ben
Vandaag om 19:02:35
Toon hier je nieuwe (model-) spooraanwinst(en)... door puntenglijder
Vandaag om 19:01:00
Langlauf tender ( Bayerische ) ombouwen naar Kurztender. door puntenglijder
Vandaag om 18:52:26
Vorarlberg (Oostenrijkse treinbaan....n-spoor) door raymond erdtsieck
Vandaag om 18:52:04
Problemen met het instellen van de Ulhenbrock 63320 decoders door Josephes
Vandaag om 18:13:19
Ombouw/Pimpen Bolle neuzen door bollen neus
Vandaag om 18:01:07
Brugstekkers 8-polig: alle identiek? door Klaas Zondervan
Vandaag om 17:21:46
Digikeijs DR4018, bij schakelen valt spanning op baan weg, knippert verlichting door Timo
Vandaag om 17:13:37
Liliput 6400 met 2 motoren, onderdelen gezocht, en hoe aandrijving openen? door BartvD
Vandaag om 17:04:37
Bruggen-IG: De brug van Oosterbeek door Gerco van Beelen
Vandaag om 16:59:35
Videoserie: Rocrail voor beginners door AlbertG
Vandaag om 16:58:08
Dram Dhu Distillery in schaal 1:76 (00) door Wim1969
Vandaag om 16:54:24
Cranicher Altbahn door Arjen52
Vandaag om 16:24:26
Baanplan La Vie de la Reine - H0 Fleischmann profi door freekvo
Vandaag om 15:57:37
Cubana door sdz1976
Vandaag om 15:50:30
Depot + vervolg Vlieringen-2 door Hans Reints
Vandaag om 15:48:08
Halling aandrijftechniek catalogus. door Silvolde
Vandaag om 15:27:57
ECoS II (ESU), of Central Station (Marklin)? door Jan-Peter
Vandaag om 15:14:12
  

Auteur Topic: Pret met Arduino  (gelezen 26525 keer)

Ad Cleijsen

  • Offline Offline
  • Berichten: 560
Re: Pret met Arduino
« Reactie #135 Gepost op: 24 augustus 2019, 17:51:15 »
zou zo maar kunnen kloppen. W10 in ieder geval.

Ad Cleijsen

  • Offline Offline
  • Berichten: 560
Re: Pret met Arduino
« Reactie #136 Gepost op: 04 september 2019, 19:50:05 »
Timo,

Ben aan het proberen (nog bij video 1), maar ik krijg 'een error op gedurende laden van de schets'.
avrdude: stk500v2-recieveMessager() : timeout

??
zou dat met windows 10 te maken kunnen hebben?

gr. Ad

Timo

  • Team encyclopedie
  • Offline Offline
  • Berichten: 4642
Re: Pret met Arduino
« Reactie #137 Gepost op: 04 september 2019, 19:56:58 »
In de basis, nee :angel: Windows 10 is niet veel anders dan Windows 7 daarin. Hoe zeker ben je er van dat je:

- de juiste driver hebt geïnstalleerd?
- de juist COM-poort hebt geselecteerd?
- het juiste bord (+ andere instellingen!) hebt geselecteerd?

De complete error hier plaatsen kan helpen om de fout te vinden.


Timo
Verzonden vanaf mijn desktop met Firefox

Zilte

  • Gast
Re: Pret met Arduino
« Reactie #138 Gepost op: 04 september 2019, 19:58:32 »
@ Ad Cleijsen: gaat u in het programma van Arduino bij: Bestand > Voorbeelden > Basics en dan klik Blink? Dit gaat bij mij onder Windows 10 vlekkeloos.

@Timo: het laden van de schets kan zonder de Arduino aangesloten te hebben. Uit de reactie van heer Cleijsen maak ik op dat het probleem zich daar voordoet en niet bij het uploaden naar de Arduino. Zou het deïnstalleren van de software en een her-ïnstallatie soelaas bieden?
« Laatst bewerkt op: 04 september 2019, 20:02:20 door Zilte. Reden: tekst toegevoegd en aangepast »

Timo

  • Team encyclopedie
  • Offline Offline
  • Berichten: 4642
Re: Pret met Arduino
« Reactie #139 Gepost op: 04 september 2019, 20:28:23 »
Uit de reactie van heer Cleijsen maak ik op dat het probleem zich daar voordoet en niet bij het uploaden naar de Arduino.
Maar het is wel degelijk met uploaden ;) stk500v2 wordt alleen aangeroepen tijdens het programmeren (stk500 is het protocol voor de AVR bootloaders).

Zou het deïnstalleren van de software en een her-ïnstallatie soelaas bieden?
Dus nee :)


Timo
Verzonden vanaf mijn desktop met Firefox

RudyB

  • Offline Offline
  • Berichten: 544
  • EMV
    • RudysModelRailway
Re: Pret met Arduino
« Reactie #140 Gepost op: 04 september 2019, 20:32:50 »
Things you can try:

Use the official factory driver:
http://www.wch.cn/download/CH341SER_EXE.html

Disable Windows 10 signed driver enforcement:
https://ph.answers.acer.com/app/answers/detail/a_id/38288/~/windows-10%3A-disable-signed-driver-enforcement

Temporary disable your anti virus program.

Run the install as administrator (Right click, select Run as administrator).

Timo

  • Team encyclopedie
  • Offline Offline
  • Berichten: 4642
Re: Pret met Arduino
« Reactie #141 Gepost op: 04 september 2019, 20:42:08 »
De CH340 is inderdaad de meest gebruikte chip voor Arduino clones uit China, grote kans dat die erop zit. Maar die driver is gewoon ondertekend, zou dus niet de moeite nemen om de driver handtekeningcontrole uit te zetten zonder even verder te kijken.

Om te kijken of je de juiste driver hebt en of deze correct werkt kan je simpelweg apparaatbeheer openen. Onder poorten zou hij dan moeten verschijnen als je de USB erin drukt. Moet verschijnen zonder uitroepteken en zal erachter het COM-nummer tonen.


Timo
Verzonden vanaf mijn desktop met Firefox

Ad Cleijsen

  • Offline Offline
  • Berichten: 560
Re: Pret met Arduino
« Reactie #142 Gepost op: 07 september 2019, 12:56:02 »
Timo,

Een en ander leidt weer tot een paar vragen.

board gecontroleerd (uno)
com = com9
driver zou correct moeten zijn.

Bij Blink uploaden. Ik zie dat dit gebeurt, de LED's op de arduino blinken op (DK en XT), maar LED 9 gaat niet knipperen, zoals op het voorbeeld filmpje.
Heb bij het uploaden geen foutmeldingen meer, dat is dus de eerste winst.

Ik ga verder met filmpje 2, misschien brengt dat wat nieuwe wijsheid.

Groet

ETH023

  • Offline Offline
  • Berichten: 323
Re: Pret met Arduino
« Reactie #143 Gepost op: 07 september 2019, 21:00:35 »
@Ad,

Is de arduino van merk Wavgat? Die werken namelijk niet goed. Heb ik ook problemen mee ondervonden helaas.

Mvg
Erwin
Erwin

Timo

  • Team encyclopedie
  • Offline Offline
  • Berichten: 4642
Re: Pret met Arduino
« Reactie #144 Gepost op: 08 september 2019, 20:03:52 »
Hoi Ad,

Dus nadat je op "Upload" hebt geklikt krijg je in de groene balk (en die is niet rood geworden) "Done uploading"? Of een Nederlandse versie als je die gebruikt.

Dan zou de led op pin 13 (niet 9) moeten knipperen. Anders er eens een externe led (met weerstand!) aan hangen.

@ETH023, daar heb ik nooit klachten over gezien dus
- of je deed iets fout
- of je had een maandag morgen model
- of het was in de tijd van de nep FTDI chips.


Timo
Verzonden vanaf mijn desktop met Firefox

Fritsprt

  • Online Online
  • Berichten: 1324
Re: Pret met Arduino
« Reactie #145 Gepost op: 08 september 2019, 20:49:18 »

@ETH023, daar heb ik nooit klachten over gezien dus
@Ad,

Is de arduino van merk Wavgat? Die werken namelijk niet goed. Heb ik ook problemen mee ondervonden helaas.

Mvg
Erwin



Ik heb daar vaker iets over gelezen. Volgens mij hebben ze een afwijkende bootloader. Maar aangezien er wel een sketch geupload kan worden zal het daar niet aan liggen.

Gr. Frits

RudyB

  • Offline Offline
  • Berichten: 544
  • EMV
    • RudysModelRailway
Pret met Arduino 39 - OLED display SSD1306
« Reactie #146 Gepost op: 09 september 2019, 11:34:31 »
We gaan de ultrasone afstand meter uitbreiden met een OLED display. Samen met een batterij wordt het zo een portable meetinstrument. Daar gaat het eigenlijk niet om, die maken we just for fun. Het gaat om de OLED display ... als we die eenmaal aan de praat hebben zijn daar vele leuke en nuttige toepassingen mee te maken.

Link naar Fun with Arduino 39 - OLED dDisplay SSD1306



Ad Cleijsen

  • Offline Offline
  • Berichten: 560
Re: Pret met Arduino
« Reactie #147 Gepost op: 16 september 2019, 18:52:13 »
Alhoewel ik van fout naar fout ga, toch een vordering.

Dit is de foutmelding op de DCC decoder

Arduino:1.8.9 (Windows 10), Board:"Arduino Nano, ATmega328P"

Build-opties gewijzigd, alles wordt opnieuw gebuild
De schets gebruikt 930 bytes (3%)  programma-opslagruimte. Maximum is 30720 bytes.
Globale variabelen gebruiken 9 bytes (0%) van het dynamisch geheugen. Resteren 2039 bytes voor lokale variabelen. Maximum is 2048 bytes.
avrdude: ser_open(): can't set com-state for "\\.\COM9"

En dit is de foutmeding op de UNO -

geen, verhip het werkt zoals bedoeld en als ik speel met tijdstip lampie aan, lampie uit. Het werkt.

Bedankt voor de input, ik ga weer verder.

Groeten Ad

Timo

  • Team encyclopedie
  • Offline Offline
  • Berichten: 4642
Re: Pret met Arduino
« Reactie #148 Gepost op: 16 september 2019, 21:28:08 »
Heb jij heel toevallig de Arduino IDE uit de Windows store gehaald?


Timo
Verzonden vanaf mijn desktop met Firefox

Ad Cleijsen

  • Offline Offline
  • Berichten: 560
Re: Pret met Arduino
« Reactie #149 Gepost op: 17 september 2019, 11:36:41 »
Timo,
Geen idee.
Volgende zoektocht.

Overigens wel toppiemoment als dan in een keer zo'n dom lampie gaat branden, zoals je bedoeld had.

Groet Ad